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File Menu Commands

The File menu offers the following commands.

Print
Prints the sky display.

Print Preview
Allows you to see how the printed sky display will look.

Print Setup
Selects a printer and printer connection.

Exit
Exits the SkyView application.



Options Menu Commands

The Options menu offers the following commands.

Location
Allows you to set the observer's location on the earth.

Limiting Magnitude
Allows you to set the limiting magnitude of stars in the sky display.

Orientation
Allows you to set the orientation of the sky display.

Lines
Allows you to specify which lines--ecliptic, celestial equator, galactic equator, or equatorial coordinate 
system--should be included in the sky display.



Time Menu Commands

The Time menu offers the following commands.

Date and Time
Allows you to set the date and time, and to specify whether daylight-saving time is in effect.

Subtract 1 Hour
Subtracts one hour from the time.

Add 1 Hour
Adds one hour to the time.

Subtract 1 Day
Subtracts one day from the date.

Add 1 Day
Adds one day to the date.

Subtract 1 Week
Subtracts one week from the date.

Add 1 Week
Adds one week to the date.



Colors Menu Commands

The Colors menu offers the following commands.

Background
Allows you to set the color of the window background.

Mercury
Allows you to set the color used for the symbol that represents Mercury in the sky display.

Venus
Allows you to set the color used for the symbol that represents Venus in the sky display.

Mars
Allows you to set the color used for the symbol that represents Mars in the sky display.

Jupiter
Allows you to set the color used for the symbol that represents Jupiter in the sky display.

Saturn
Allows you to set the color used for the symbol that represents Saturn in the sky display.

Ecliptic
Allows you to set the color used for the ecliptic in the sky display.

Celestial Equator
Allows you to set the color used for the celestial equator in the sky display.

Galactic Equator
Allows you to set the color used for the galactic equator in the sky display.

Equatorial Coordinate System
Allows you to set the color used for the equatorial coordinate system lines in the sky display.

Default Colors
Restores the colors to the values that SkyView started up with.



View Menu Commands

The View menu offers the following commands.

Toolbar
Shows or hides the toolbar.

Status Bar
Shows or hides the status bar.



Help Menu Commands

The Help menu offers the following commands, which provide you assistance with this application.

Contents
Displays the help contents for SkyView.

Procedures
Displays help for SkyView procedures.

Commands
Displays help for SkyView commands.

Search for Help On
Allows you to search for a keyword in SkyView help.

Using Help
Provides general instructions on using help.

About SkyView
Displays program information, version number, and copyright.



Exit Command (File Menu)

Use this command to end your SkyView session. You can also use the Close command on the application
Control menu.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Location Command (Options Menu)

Use this command to set the observer's location on the earth. This command displays the Location dialog 
box.



Limiting Magnitude Command (Options Menu)

Use this command to set the limiting magnitude of stars in the sky display. This command displays the 
Limiting Magnitude dialog box.



Orientation Command (Options Menu)

Use this command to set the orientation of the sky display. This command displays the Orientation dialog 
box.



Lines Command (Options Menu)

Use this command to specify which lines--ecliptic, celestial equator, galactic equator, or equatorial 
coordinate system--should be included in the sky display. This command displays the Lines dialog box.



Date and Time Command (Time Menu)

Use this command to set the date and time, and to specify whether daylight-saving time is in effect. This 
command displays the Date and Time dialog box.



Subtract 1 Hour Command (Time Menu)

Use this command to subtract one hour from the time.



Add 1 Hour Command (Time Menu)

Use this command to add one hour to the time.



Subtract 1 Day Command (Time Menu)

Use this command to subtract one day from the date.



Add 1 Day Command (Time Menu)

Use this command to add one day to the date.



Subtract 1 Week Command (Time Menu)

Use this command to subtract one week from the date.



Add 1 Week Command (Time Menu)

Use this command to add one week to the date.



Background Command (Colors Menu)

Use this command to change the color of the window background. This command displays the Colors 
dialog box.



Mercury Command (Colors Menu)

Use this command to change the color of the symbol used to represent Mercury in the sky display. This 
command displays the Colors dialog box.



Venus Command (Colors Menu)

Use this command to change the color of the symbol used to represent Venus in the sky display. This 
command displays the Colors dialog box.



Mars Command (Colors Menu)

Use this command to change the color of the symbol used to represent Mars in the sky display. This 
command displays the Colors dialog box.



Jupiter Command (Colors Menu)

Use this command to change the color of the symbol used to represent Jupiter in the sky display. This 
command displays the Colors dialog box.



Saturn Command (Colors Menu)

Use this command to change the color of the symbol used to represent Saturn in the sky display. This 
command displays the Colors dialog box.



Ecliptic Command (Colors Menu)

Use this command to change the color used for the ecliptic in the sky display. This command displays the 
Colors dialog box.



Celestial Equator Command (Colors Menu)

Use this command to change the color used for the celestial equator in the sky display. This command 
displays the Colors dialog box.



Galactic Equator Command (Colors Menu)

Use this command to change the color used for the galactic equator in the sky display. This command 
displays the Colors dialog box.



Equatorial Coordinate System Command (Colors Menu)

Use this command to change the color used for the equatorial coordinate system lines in the sky display. 
This command displays the Colors dialog box.



Default Colors Command (Colors Menu)

Use this command to restore the colors that SkyView started up with.



Toolbar Command (View Menu)

Use this command to display and hide the toolbar, which includes buttons for some of the commands in 
SkyView. A check mark appears next to the menu item when the toolbar is displayed.

See Toolbar for help on using the toolbar.



Decrement the Limiting Magnitude by 0.5 Magnitudes

This toolbar button allows you to quickly decrement the limiting magnitude of stars in the sky display by 
0.5 magnitudes.



Increment the Limiting Magnitude by 0.5 Magnitudes

This toolbar button allows you to quickly increment the limiting magnitude of stars in the sky display by 0.5
magnitudes.



Toggle the Ecliptic, Celestial Equator, and Galactic Equator

This toolbar button allows you to quickly toggle the display of the ecliptic, celestial equator, and galactic 
equator.



Toggle the Equatorial Coordinate System Lines

This toolbar button allows you to quickly toggle the display of the equatorial coordinate system lines.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar. The toolbar 
provides quick mouse access to some of the commands used in SkyView.

To hide or display the toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Decrement the limiting magnitude of stars in the sky display by 0.5 magnitudes.

Increment the limiting magnitude of stars in the sky display by 0.5 magnitudes.

Toggle the ecliptic, celestial equator, and galactic equator.

Toggle the equatorial coordinate system lines.

Subtract one hour from the time.

Add one hour to the time.

Subtract one day from the date.

Add one day to the date.

Subtract one week from the date.

Add one week to the date.

Display program information, version number, and copyright.

Display help for clicked on buttons, menus, and windows.



Status Bar Command (View Menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to 
the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the SkyView window. To display or hide the status bar, use 
the Status Bar command in the View menu.

The status bar describes actions of menu items as you use the arrow keys to navigate through menus. 
This area similarly shows messages that describe the actions of toolbar buttons as you depress them, 
before releasing them. If after viewing the description of the toolbar button command you wish not to 
execute the command, then release the mouse button while the pointer is off the toolbar button.



Contents Command (Help Menu)

Use this command to display the opening screen of Help. From the opening screen, you can jump to step-
by-step instructions for using SkyView and various types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Procedures Command (Help Menu)

Use this command to display help for SkyView procedures.



Commands Command (Help Menu)

Use this command to display help for SkyView commands



Search for Help On Command (Help Menu)

Use this command to search for a keyword in SkyView help.



Using Help Command (Help Menu)

Use this command for instructions about using Help.



About SkyView Command (Help Menu)

Use this command to display program information, the version number, and the copyright notice of your 
copy of SkyView.



Context Help Command

Use the Context Help command to obtain help on some portion of SkyView. When you choose the 
toolbar's Context Help button, the mouse pointer will change to an arrow and question mark. Then click 
somewhere in the SkyView window, such as another toolbar button. The Help topic will be shown for the 
item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window. It contains the name of the application window.

To move the window, drag the title bar. Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button

Maximize button

Minimize button

Name of the application

Name of the document

Restore button



Size Command (System Menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move. 
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note: This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move Command (Control Menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

Note: This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize Command (Application Control Menu)

Use this command to reduce the SkyView window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize Command (System Menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Close Command (Control Menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes a SkyView window or dialog box



Restore Command (Control Menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to Command (Application Control Menu)

Use this command to display a list of all open applications. Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options.

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar. This option does not affect
applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap. This option does not affect applications 
reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.





Print Command (File Menu)

Use this command to print the sky display. This command presents a Print dialog box, where you may 
specify the range of pages to be printed, the number of copies, the destination printer, and other printer 
setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print Dialog Box

The following options allow you to specify how the sky display should be printed.

Printer
This is the active printer and printer connection. Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so you can select a printer and printer connection.

Print Range
Specify the pages you want to print:

All prints the entire document.
Selection prints the currently selected text.
Pages prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing. Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that SkyView is sending output to the printer. The page 
number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview Command (File Menu)

Use this command to display the sky display as it would appear when printed. When you choose this 
command, the main window will be replaced with a print preview window in which one or two pages will 
be displayed in their printed format. The print preview toolbar offers you options to view either one or two 
pages at a time; move back and forth through the pages; zoom in and out of pages; and initiate a print 
job.



Print Preview Toolbar

The print preview toolbar offers you the following options.

Print
Bring up the print dialog box, to start a print job.

Next Page
Preview the next printed page.

Prev Page
Preview the previous printed page.

One Page / Two Page
Preview one or two printed pages at a time.

Zoom In
Take a closer look at the printed page.

Zoom Out
Take a larger look at the printed page.

Close
Return from print preview to the sky display window.



Print Setup Command (File Menu)

Use this command to select a printer and a printer connection. This command presents a Print Setup 
dialog box, where you specify the printer and its connection.



Print Setup Dialog Box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use. Choose the Default Printer; or choose the Specific Printer option 
and select one of the current installed printers shown in the box. You install printers and configure 
ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the sky display is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of 
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.





Description of SkyView

SkyView is one of a growing number of astronomy applications for Microsoft Windows. The program is 
designed to perform many of the functions of a planetarium. As the name suggests, SkyView shows you a
view of the sky. The whole sky. It shows everything that you can see in the sky from one location at one 
time.

SkyView displays

The positions of the sun, moon, and all planets visible with the naked eye.

All stars down to a limiting magnitude you select.

The positions of the ecliptic, celestial equator, galactic equator, and equatorial coordinate system 
lines in any combination.

SkyView allows you to

See the sky as it looked or will look at any date and time between the years 1900 and 2100, 
inclusive.

See the sky as it looks from any location on the earth.

Orient the sky display so that the North, South, East, or West horizon is positioned at the bottom 
of the window.

Print and print preview the sky display.

Select the colors used for the window background and many of the objects in the sky display.

SkyView was developed with a limited goal in mind. It does not try to do everything and display everything
related to astronomy. SkyView is not the fastest program, and it is not the most accurate. SkyView does 
not display small sections of the sky filled with dim stars that you can only see through binoculars or a 
telescope. It does not display deep sky objects such as nebulae, star clusters, or galaxies. It does not 
label constellations or individual stars.

SkyView is free. If you enjoy playing around with it, thats great. If not, let me know why.



Software and Hardware Requirements

Software Requirements
SkyView requires Microsoft Windows 3.1, running in 386 Enhanced Mode.

Hardware Requirements
For the best performance, SkyView should be run on a computer equiped with at least a 486 CPU. Not 
only are such computer fast, they are all equiped with a math coprocessor. Computers equiped with 
486SX and 386 CPUs may contain an optional math coprocessor chip, but many do not. SkyView 
performs very many trigonometric calculations to generate the sky display, and these calculations take 
significantly longer to perform without a math coprocessor. A sky display that takes seconds to generate 
on a 486 system will take minutes on a 386 system without a math coprocessor.

SkyView requires that you run Windows in a video mode that can display 256 colors. It will run in a 16-
color video mode, but the sky display won't look very good. I've made no attempt to write the program for 
or test it in a 16-color video mode. Hey, this is 1993. Decent hardware is pretty cheap.

SkyView requires 800KB of hard disk space.



Installation

SkyView Distribution
SkyView is distributed as a compressed file called skyview.zip. This archive was created using the utility 
pkzip 2.04g. The file skyview.zip contains the following files.

readme.1st Description of SkyView and installation instructions
skyview.exe Executable
skyview.hlp Help file
location.dat Location database
pelement.dat Orbital elements and other data for the planets
ybsc64b.dat Star database
spin.vbx Spin buttons for the dialog boxes
threed.vbx Three-dimensional controls for the dialog boxes

Installation Instructions
Use the following steps to install SkyView.

1. Create a directory to contain the SkyView files.
File Manager
a. Choose the command Create Directory from the File menu.
b. Type skyview as the directory name.

Norton Desktop for Windows
a. Choose the command Make Directory from the File menu.
b. Type skyview as the directory name.

DOS Command Line
a. Type md skyview on the command line.

2. Copy skyview.zip to the directory you just created.
File Manager or Norton Desktop for Windows
a. Drag the file skyview.zip to the directory you just created.

DOS Command Line
a. Type copy skyview.zip c:\skyview on the command line.

3. Uncompress the distribution file.
File Manager or Norton Desktop for Windows
a. Use your favorite Windows compression/decompression utility to uncompress the file skyview.zip.

You have probably associated the .zip extension with this utility, so you should be able to just 
double-click on the name to uncompress the file.

DOS Command Line
a. Type pkunzip skyview on the command line.

4. Create a new group to contain SkyView. If you wish to put the SkyView icon in an existing group, skip 
to step 5.
Program Manager
a. Choose the New command from the File menu.
b. Select the Program Group radio button.
c. Type SkyView in the Description field.



Norton Desktop for Windows
a. Choose the New command from the File menu.
b. Select the Group radio button.
c. Type SkyView in the Title field.

5. Add the SkyView icon to a group.
Program Manager
a. Choose the New command from the File menu.
b. Select the Program Item radio button.
c. Type SkyView in the Description field.
d. Type c:\skyview\skyview.exe in the Command Line field.

Norton Desktop for Windows
a. Choose the New command from the File menu.
b. Select the Item radio button.
c. Type SkyView in the Title field.
d. Type c:\skyview\skyview.exe in the Program/Document/Script field.

or, simply drag the file skyview.exe into the group or onto the desktop.



How to Register

Register? Yeah, right. SkyView is free!

Even though SkyView is free, it is not public domain software. See Copyright for my legal copyright notice
and a list of rights I grant to users of SkyView.



Copyright

Copyright © 1993 Stephen Michael Schimpf. All Rights Reserved.

Permission is granted to any individual or institution to use, copy, or distribute this software, provided all of
the original files are included unmodified and that it is not sold for profit.



Contents of the SkyView Window

Sky Display
The sky display shows the entire sky visible to an observer at a given location at a given date and time. 
Imagine lying on your back far away from buildings, mountains, or trees, and looking straight up at a 
cloudless sky. The four cardinal directions (North, South, East, and West) are at the top, bottom, right, 
and left sides of the display, but their postions depend on the sky display orientation you choose. See 
Changing the Sky Display Orientation for step-by-step instructions on how to set the sky display 
orientation.

The circle around the edge of the sky is the horizon, and the center of the sky display is the zenith.

You can position and size the SkyView window to your liking. When you exit SkyView, the window size 
and position is saved and will be restored when you start the program again.

Sun and Moon
The sky display may contain the sun and the moon. The sun is always displayed as a yellow circle. Even 
though you can't really see stars and planets when the sun is above the horizon, SkyView shows them as 
if you could.

The moon is displayed using the colors white for the side illuminated by the sun, and dark gray for the 
dark side.

Planets
The sky display may contain one, some, or all of the planets visible by the naked eye. The positions of the
planets are indicated by their traditional symbols. The colors of these symbols can be changed. See 
Changing the Sky Display Colors for step-by-step instructions on how to change the colors of these 
symbols.

The positions of the planets Uranus, Neptune, and Pluto are never shown as these planets cannot be 
seen without the aid of binoculars or a telescope.

Stars
The number of stars in the sky display depends on the selected limiting magnitude. The greater the 
limiting magnitude, the more stars will be displayed and the longer it will take to generate the display. See 
Changing the Number of Stars Displayed for step-by-step instructions on how to change the limiting 
mangitude.

The stars are represented in the display by symbols of different sizes and colors. Naturally, larger 
symbols represent brighter stars and smaller symbols represent dimmer stars. Although the star database
used by SkyView contains information about the colors of all the stars, only stars in the top three 
brightness levels are displayed in color. Only the brightest stars in the real sky appear to be colored. The 
colors of the stars are subtle. In addition to white, bright stars may appear to have a touch of blue, yellow, 
or red in them. Dimmer stars are displayed using only white and a few levels of gray.

Lines
You can choose to display lines on the celestial sphere representing the ecliptic, celestial equator, 
galactic equator, and equatorial coordinate system lines. See Adding Lines to the Sky Display for step-by-
step instructions on how to add these lines to the sky display.

Legend
The upper right corner of the SkyView window contains a legend of symbols used in the sky display. 
These symbols include those for the sun, moon, all planets visible with the naked eye, the ecliptic, 



celestial equator, galactic equator, and equatorial coordinate system lines.

A symbol for a given object appears in the legend only if that object is currently visible in the sky display. If
the object is not visible because it is below the horizon, no symbol appears.

Date and Time Information
The lower right corner of the SkyView window contains date and time information. This information 
includes the local time, universal time, local sidereal time, and the Julian date.





Adding Lines to the Sky Display

SkyView can display the ecliptic, celestial equator, galactic equator, and equatorial coordinate system 
lines.

To add these lines to the sky display
1. Choose the Lines command from the Options menu. This will display the Lines dialog box.
2. Specify the lines you want or don't want in the sky display by checking or unchecking the check boxes

labeled Ecliptic, Celestial Equator, Galactic Equator, and Equatorial Coordinates.
3. Choose the OK button or press the Enter key to return to the sky display.

Another way to add these lines to the sky display is to use some of the buttons on the toolbar.



Adding a Location to the Location Database

SkyView allows you to add locations to the location database.

To add a location to the location database
1. Choose the Location command from the Options menu. This will display the Location dialog box.
2. Choose the Add button in the Location dialog box. This will display the Edit Location dialog box.
3. Type the name of the location into the edit control in the Location group. The name should be no 

more than 24 characters long.
4. Type the latitude in decimal degrees into the edit control in the Latitude group. Select the North or 

South radio button for this latitude. Do not use a minus sign to indicate South latitude.
5. Type the longitude in decimal degrees into the edit control in the Longitude group. Select the East or 

West radio button for this longitude. Do not use a minus sign to indicate West longitude.
6. Type the time zone in decimal hours into the edit control in the Time Zone group. The time zone is the

difference between local time and Universal time for that time zone. Select the Ahead or Behind radio 
button for this time zone. Do not use a minus sign to indicate time zones that are behind Universal 
Time.

7. Choose the OK button or press the Enter key to return to the Location dialog box.



Changing the Date and Time

SkyView can display the sky for any date and time between the years 1900 and 2100, inclusive.

To change the date and time
1. Choose the Date and Time command from the Time menu. This will display the Date and Time dialog 

box.
2. Specify the date by typing the year, month number, and day into the edit controls labeled Year, Month,

and Day or by using the spin buttons next to those edit controls.
3. Specify the time by typing the hour, minute, and second into the edit controls labeled Hour, Minute, 

and Second or by using the spin buttons next to those edit controls.
4. Specify whether daylight-saving time is or is not in effect by checking or unchecking the check box 

labeled Daylight-Saving Time.
5. Choose the OK button or press the Enter key to return to the sky display.

To decrement or increment the date or time
Use the other commands on the Time menu. These commands--Subtract 1 Hour, Add 1 Hour, and so on--
allow you to quickly subtract or add one hour, day, or week to the date and time. 

Another way to increment or decrement the date and time is to use some of the buttons on the toolbar.



Changing the Number of Stars Displayed

SkyView can show all the stars in the sky down to a limiting magnitude of 6.4.

To change the limiting magnitude
1. Choose the Limiting Magnitude command from the Options menu. This will display the Limiting 

Magnitude dialog box.
2. Specify the limiting magnitude by moving the scroll bar back and forth until the number displayed 

above it is the limiting magnitude you want.
3. Choose the OK button or press the Enter key to return to the sky display.

Another way to change the number of stars displayed is to use some of the buttons on the toolbar.



Changing the Observer's Location

SkyView can display the sky as seen by an observer from any location on the earth.

To change the observer's location
1. Choose the Location command from the Options menu. This will display the Location dialog box.
2. Select a location from the Location combo box.
3. Choose the OK button or press the Enter key to return to the sky display.

The Location dialog box can also be used to edit, add, or delete locations. See Location Dialog Box for 
instructions.



Changing the Sky Display Colors

SkyView allows you to select the colors used to display some of the objects in the sky display, and the 
color of the window background.

To change any color
1. Choose one of the commands on the Colors menu except Default Colors. This will display the Colors 

dialog box.
2. Select a color from the Colors radio group.
3. Choose the OK button or press the Enter key to return to the sky display.

To restore the default colors
The Default Colors command on the Colors menu returns all the sky display colors to the values the 
program started up with.



Changing the Sky Display Orientation

SkyView can display the sky with any of the four cardinal directions oriented at the bottom of the window.

To change the sky display orientation
1. Choose the Orientation command on the Options menu. This will display the Orientation dialog box.
2. Select which horizon should be positioned at the bottom of the window from the Horizons radio group.
3. Choose the OK button or press the Enter key to return to the sky display.



Deleting a Location From the Location Database

SkyView allows you to delete locations from the location database.

To delete a location from the location database
1. Choose the Location command from the Options menu. This will display the Location dialog box.
2. Select a location from the Location combo box.
3. Choose the Delete button. A Confirmation dialog box will appear asking you to confirm that you want 

to delete the location. Choose the OK button in the Confirmation dialog box.
4. Choose the OK button or press the Enter key to return to the sky display.



Editing the Data for a Location

SkyView allows you to edit the data associated with a location in the location database.

To edit the data for a location in the location database
1. Choose the Location command from the Options menu. This will display the Location dialog box.
2. Choose the Edit button in the Location dialog box. This will display the Edit Location dialog box.
3. Modify the name of the location in the edit control in the Location group. The name should be no more

than 24 characters long.
4. Modify the latitude in the edit control in the Latitude group. Select the North or South radio button for 

this latitude. Do not use a minus sign to indicate South latitude.
5. Modify the longitude in the edit control in the Longitude group. Select the East or West radio button 

for this longitude. Do not use a minus sign to indicate West longitude.
6. Modify the time zone in the edit control in the Time Zone group. The time zone is the difference 

between local time and Universal time for that time zone. Select the Ahead or Behind radio button for 
this time zone. Do not use a minus sign to indicate time zones that are behind Universal Time.

7. Choose the OK button or press the Enter key to return to the Location dialog box.





Tools Used

Hardware
In case you're interested, SkyView was developed using the following hardware.

Tri-Star Computer Corporation 486/33 EISA system

16MB of RAM

Maxtor LXT-340S 340MB SCSI hard drive

UltraStor 24F-10 EISA SCSI controller

Diamond SpeedStar HiColor video card

NEC MultiSync 5FG monitor

Hewlett-Packard LaserJet IIIp laser printer

I don't have access to a wide variety of PC systems, so I can't try SkyView out on a wide variety of 
hardware and software combinations. SkyView has been tested on other 486 systems manufactured by 
Tri-Star Computer Corporation and Gateway 2000. These systems were equipped with Diamond 
SpeedStar HiColor, SpeedStar 24, and ATI Graphics Ultra Pro video boards running in 1024x768x256 
and 800x600x256 modes. No 386 systems were tested.

SkyView should run just fine on any hardware that runs Windows, but you never know. If you have trouble
running SkyView, let me know. If it doesn't appear to like a certain video mode or printer, let me know.

Software
The computer used to develop SkyView ran the following operating system.

Microsoft MS-DOS 6.0

Microsoft Windows 3.1

Norton Desktop for Windows 2.2

You don't need MS-DOS 6.0 or the Norton Desktop for Windows to run SkyView, but it wouldn't hurt. You 
definitely need Window 3.1 to run SkyView. Also, you need to be running Windows in 386 Enhanced 
Mode. Hey, if you are still using Windows 3.0, now you have a great reason to upgrade!

This version of SkyView was written entirely in C++ using the Microsoft Foundation Class Library 2.00. 
The following development tools were used.

Microsoft Visual C++ Professional Edition 1.00

Microsoft Visual Control Pack 1.00

Microsoft Word for Windows 2.0b

Visual C++, the Visual Control Pack, and the new version of the Microsoft Foundation Class Library are 
fantastic! Way to go, Microsoft!



Note About the Projection Used by SkyView

I have seen a number of astronomy programs for Windows, DOS, and the Macintosh. Some of these 
programs have an option to display the entire sky at once. These sky displays all use a very misleading 
projection of the sky on the computer screen.

It is common to think of the sky as a large sphere, the celestial sphere, and the stars being fixed on the 
inner surface of this sphere. We think of ourselves viewing the inside of this sphere from the center. Other
programs incorrectly display the sky as if we were looking at the inside of one hemisphere from a great 
distance away. Stars seem to be concentrated around the edge of the sky display rather than be 
distributed evenly across the sky. Constellations are foreshortened, as if you were viewing them at a 
shallow angle. Ask yourself this: does the real sky ever look like this? The answer is clearly no!

Look at a continent on a globe of the earth. If the continent is right in front of you it looks the way you 
expect it to look. Spin the globe so that the continent is moving away from you. The closer it gets to the 
edge of the globe the more distorted it looks. Spin the globe a little more and the continent disappears to 
the back side. This is all very normal if you are viewing the globe from a few feet away. But what if you 
were inside the globe--at the very center--and could look out and see the continents. They would always 
look the same; there would be no distortion.

The same idea applies to the stars in the sky. You are viewing a hemisphere of the celestial sphere from 
the inside, not from a great distance away. Objects near the horizon do appear larger than those that are 
higher up in the sky. This is just an optical illusion, but it is important to keep in mind when thinking about 
how the sky really looks. A constellation near the horizon will look larger than it does when it is high in the 
sky, not smaller as many other programs will display it.

You cannot display a three-dimensional surface like the celestial sphere on a two-dimension surface like a
computer screen without distortion. But there are different ways to project the 3D surface onto the 2D 
surface, and some ways are clearly better than others. I think the projection used by this program displays
the sky in a much more realistic fashion that do other programs. Constellations are somewhat distorted, 
but they are distorted in a way that more accurately simulates the appearance of the sky.



Bibliography

Windows Programming
This application could not have been written without the help of the following book.

Charles Petzold. 1992, Programming Windows 3.1, Third Edition. (Redmond, Washington: Microsoft 
Press). ISBN 1-55615-395-3.

I must admit that this book was a lot more useful to me when I was still programming Windows using C 
and the Software Development Kit. It's been over a year since I switched completely to C++ and the 
Microsoft Foundation Class Library. Even if you're using C++, it's a very good idea to not only know of but 
also understand the Windows API, and for this I certainly recommend reading Petzold.

Astronomical Calculations
For more information about the astronomical calculations performed in SkyView, refer to the following 
books.

Duffett-Smith, P. 1990, Astronomy with Your Personal Computer, Second Edition, (Cambridge: 
Cambridge University Press). ISBN 0-521-38995-X.

A useful book if you can stand the sight of BASIC code. I kept my sanity by telling myself that by 
performing the act of translating the code to C++ the gods of programming would smile upon me.

Green, R.M. 1985, Spherical Astronomy, (Cambridge: Cambridge University Press).

Ugh. Spherical astronomy. Enough said.

Meeus, J. 1991, Astronomical Algorithms. (Richmond: Willmann-Bell). ISBN 0-943396-35-2.

This is the book to get for astronomical calculations.
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Contacting the Author

If you have any problem running SkyView, please contact me. Hey, I may even be able to figure out 
what's wrong and to find a way to fix it. If you have any comments about SkyView--negative as well as 
positive--I'd also like to hear those. Bug reports are very welcome (bugs? In SkyView? NO! I DON'T 
BELIEVE IT!), but please be sure to tell me--step by step--what I have to do to reproduce the bug.

Now that I've finished this version of SkyView, I'm going to lock myself in my room and play guitar for a 
long, long time, but one day I'll emerge and give working on another version of SkyView a passing 
thought. So, if you have any suggestions for features you'd like to see in a future version of SkyView, 
please let me know.

Ways to contact me
1. The easiest and fastest way to contact me--provided you have Internet access--is to sent email to my 

account at work.

stephen@eggneb.astro.ucla.edu

I check my mail frequently during every workday. If you send mail to this address on the weekend it 
may be a day or two before I read it and reply.

2. If you can't send email, you can send a letter to my home address. If, for some reason, only hearing 
the sound of my voice will do, you can use my home phone number to reach me at a reasonable 
hour. Don't worry, I'll let you know very quickly if you call at an unreasonable hour.

Stephen Michael Schimpf
2444 West 230th Street
Torrance, CA 90501-5242
(310) 530-6766

3. Finally, you can send a letter to my work address, or can call me at work.

Stephen Michael Schimpf, Programmer/Analyst II
University of California, Los Angeles
Department of Astronomy
8979 Math Sciences Building
Los Angeles, CA 90024-1562
(310) 825-5183



Version History

Version 2.00 (Wednesday, 11 August 1993)

Created with Microsoft Visual C++ Professional Edition 1.00.

Combined the sky display, legend, and time information into one window. Version 1.00 used two 
windows.

Added support for printing and print preview of the sky display.

Added the toolbar.

Added the status bar.

Added context-sensitive help.

The symbols for the sun, moon, and planets in the legend are now displayed only if the 
corresponding objects appear in the sky display. Similarly, the symbols for the ecliptic, celestial equator, 
galactic equator, and equatorial coordinate system lines are only displayed if the corresponding lines 
appear in the sky display.

Improved some of the dialog boxes by adding spin buttons where appropriate.

Changed the Location dialog box. This dialog box now displays only a list of locations. You can 
easily add and delete locations from the database, and can edit the information for any location. You will 
be asked for confirmation before any location is deleted from the database. Adding and editing location 
data now takes place in the new Edit Location dialog box.

Moved the Limiting Magnitude, Orientation, and Lines commands from the Display menu to the 
Options menu. The Display menu was removed.

Added buttons to the toolbar to increment and decrement the limiting magnitude of stars in the 
sky display by 0.5 magnitudes.

Moved the Date and Time command to the new Time menu. Added items to that menu to make it 
easy to increment and decrement the time by one hour, one day, and one week. Buttons on the toolbar 
duplicate these six menu commands.

Added buttons to the toolbar to make it easier to add lines to and remove lines from the sky 
display. One button toggles the ecliptic, celestial equator, and galactic equator. The other button toggles 
the equatorial coordinate system lines.

Selecting the Default Colors item on the Colors menu previously restored the colors used for 
items in the sky display to factory values. This command now restores the colors to the default values you
selected, the ones in effect when you last exited SkyView. This allows you to experiment with the colors 
and easily restore them to the values you had previously decided upon.

Improved the display of the moon.

Practically rewrote the entire help file.

Version 1.00 (Monday, 8 February 1993)

First release for Windows 3.10 or higher. Created with Microsoft C/C++ 7.00.





Date and Time Dialog Box

The Date and Time dialog box allows you to specify the local date and time for which you want to see the 
sky. See Changing the Date and Time for step-by-step instructions.

Year
Year in the range 1900 to 2100, inclusive.

Month
Month number, in the range 1 to 12.

Day
Day of the month, in the range 1 to 31.

Hour
Hours in the range 0 to 23.

Minute
Minutes in the range 0 to 59.

Second
Seconds in the range 0 to 59.

You will be warned by a message box if you enter a value that is out of range.

Daylight-Saving Time
Check this check box if daylight-saving time is in effect. This will cause one hour to be subtracted 
from the time zone value used to convert from local time to universal time.

The state of this check box is saved when you exit SkyView and restored when you start the 
application again.

Click To

Accept the date, time, and daylight-saving time state you entered and return to the sky 
display.

Cancel any changes you made and return to the sky display.

Set the date and time values to your computer's current system date and time.

Display help for the dialog box.



Location Dialog Box

The Location dialog box allows you to specify the location from which the sky is being viewed. See 
Changing the Observer's Location for step-by-step instructions.

You can also edit location data, add locations, and delete locations from the location database. See 
Adding a Location to the Database, Deleting a Location from the Database, and Editing Date for a 
Location for step-by-step instructions.

Location
Combo box that display the names of locations in the SkyView location database.

Click To

Accept the selected location and return to the sky display.

Cancel the selection you made and return to the sky display.

Edit the data for the currently selected location.

Add a new location to the location database.

Delete the currently selected location from the location database.

Display help for the dialog box.



Edit Location Dialog Box

The Edit Location dialog box allows you to edit a previously defined location, or to define a new location. 
See Adding a Location to the Database and Editing Data for a Location for step-by-step instructions.

Location
Name of the location. The name can be up to 24 characters in length.

Latitude
Latitude in decimal degrees.

North/South
Radio buttons used to specify whether the latitude is north or south latitude. Do not use a minus sign.

Longitude
Longitude in decimal degrees.

East/West
Radio buttons used to specify whether the longitude is east or west longitude. Do not use a minus 
sign.

Time Zone
Difference in decimal hours between the location's local time and universal time.

Ahead/Behind
Radio buttons used to specify whether the time zone is ahead of or behind universal time.

Click To

Accept the location name, latitude, longitude, and time zone values you entered and return to the 
sky display.

Cancel any changes you made and return to the sky display.

Display help for the dialog box.



Limiting Magnitude Dialog Box

The Limiting Magnitude dialog box allows you to select the limiting magnitude of stars in the sky display. 
See Changing the Number of Stars Displayed for step-by-step instructions.

Remember that the more stars that are displayed, the longer it will take to generate the sky display. For 
those of you without a math coprocessor, this can make a big difference.

Selecting 6.4 as a limiting magnitude will display all 7788 stars in the SkyView database. You only see 
about half this many stars at one time because you only see half of the sky at one time. Also, you will only
be able to see down to magnitude 6 under very good seeing conditions far away from city lights. 
Therefore, under such conditions you will see about 3000 stars in the entire sky, even though you think 
you are seeing a million stars.

When you exit SkyView the currently selected limiting magnitude becomes the default.

Click To

Accept the selected limiting magnitude and return to the sky display.

Cancel any changes you made and return to the sky display.

Display help for the dialog box.



Orientation Dialog Box

The Orientation dialog box allows you to select which horizon is positioned at the bottom of the sky 
display. See Changing the Sky Display Orientation for step-by-step instructions.

When you exit SkyView the currently selected sky-display orientation is saved and is the default when you
start SkyView again.

Click To

Accept your orientation selection and return to the sky display.

Cancel any changes you made and return to the sky display.

Display help for the dialog box.



Lines Dialog Box

The Lines dialog box allows you to display or hide the ecliptic, celestial equator, galactic equator, and 
equatorial coordinate system lines. See Adding Certain Lines to the Sky Display for step-by-step 
instruction.

When you exit SkyView the changes you make in the Lines dialog box are saved. If you always want 
certain lines included in the sky display, simply select them in the dialog box. When you leave SkyView 
your preferences become the default.

Click To

Accept your selections and return to the sky display.

Cancel any changes you made and return to the sky display.

Display help for the dialog box.



Colors Dialog Box

The Colors dialog box allows you to specify the color for the window background or one of the objects in 
the sky display. See Changing the Sky Display Colors for step-by-step instructions.

Colors
Radio buttons for 27 pure colors listed by name.

When you exit SkyView the current color preferences are saved and are the default colors when you start 
SkyView again.

Click To

Accept your color selection and return to the sky display.

Cancel any changes you made and return to the sky display.

Display help for the dialog box.



Confirmation Dialog Box

The Confirmation dialog box is used to confirm whether you want a location deleted from the SkyView 
location database.

Click To

Confirm the deletion.

Cancel the deletion.





Glossary

Celestial Equator
Celestial Meridian
Celestial Poles
Celestial Sphere
Ecliptic
Equatorial Coordinate System
Galactic Equator
Great Circle
Julian Date
Local Sidereal Time
Magnitude
Precession
Sidereal Time
Terrestrial Meridian
Universal Time
Zenith



Celestial Equator

The celestial equator is the great circle formed by projecting the earth's equatorial plane onto the celestial
sphere. The celestial equator is 90 degrees from both the north and south celestial poles.

The axis of the earth's daily rotation is tilted with respect to its orbital plane, and therefore the ecliptic and 
celestial equator are tilted with respect to each other. This angle, known as the obliquity of the ecliptic, is 
currently roughly 23.5 degrees. The precession of the earth's axis causes this angle to slowly change 
over time.



Celestial Meridian

The celestial meridian is the projection of the observer's terrestrial meridian on the celestial sphere.

The observer's celestial meridian passes through both celestial poles, and passes through the observer's 
zenith. Think of the celestial meridian as an imaginary line dividing the entire visible sky in half.

The celestial meridian divides the sky into a east half and a west half. When an object in the sky is in the 
east half, it is rising, and when it is in the west half it is setting. When the object is on the celestial 
meridian, it has reached its highest point in the sky.



Celestial Poles

The celestial poles are the projection of the north and south poles of the earth's rotation onto the celestial 
sphere. The precession of the earth's axis causes the celestial poles to trace out circles on the celestial 
sphere in a period of about 25,800 years.

The north celestial pole currently lies in the constellation Ursa Minor, near the star Alpha Ursae Minoris, 
better known as Polaris or simply the North Star. The south celestial pole is currently in the constellation 
Octans.



Celestial Sphere

The celestial sphere is an imaginary sphere of immense radius centered on the earth. It provides a 
convenient surface on which to draw and study the motions of points in the sky as seen from an 
observation point on the earth.



Ecliptic

The ecliptic is the plane of the earth's orbit, and the projection of that plane onto the celestial sphere. It is 
the line in the sky along which the sun appears to move during the course of a year. The sun moves 
roughly one degree along this line every day.

Because the orbits of the naked-eye planets have inclinations of seven degrees or less with respect to the
ecliptic, you will always find these planets on or very close to this line.



Equatorial Coordinate System

The equatorial coordinate system is a coordinate system for the celestial sphere similar to the system 
used on the surface of the earth. Rather than latitude and longitude, the coordinates are right ascension 
(alpha) and declination (delta). The lines that run from celestial pole to celestial pole are lines of right 
ascension, and those that run parallel to the celestial equator are lines of declination.



Galactic Equator

The galactic equator is the plane of the Milky Way galaxy projected onto the celestial sphere. The galactic
equator and the celestial equator are inclined at an angle of about 62 degrees.

If you set the limiting magnitude of the sky display as high as it will go, you will notice that the number of 
stars in the sky display is larger around the galactic equator than in other areas of the sky. You are seeing
the concentration of stars along the plane of our galaxy.



Great Circle

A great circle is any circle on the surface of a sphere generated by a plane passing through the center of 
the sphere. Therefore, such a circle has the same radius as the sphere.



Julian Date

The Julian date is the number of days that have passed since 1200 hours universal time on 1 January, 
4713 BC. The Julian day is the number of integral days that have passed, whereas the Julian date 
includes the decimal fraction of the day that has elapsed since the preceding noon.

The Julian date system was invented in 1582 by the French scholar Joseph Scalinger. The Julian date is 
very useful because the consecutive numbering of days makes the system independent of the varying 
lengths of months and years. To find the number of days between two events, simply determine the Julian
dates of those events and subtract one date from the other.



Local Sidereal Time

Local sidereal time is the sidereal time at an observer's location. It is equal to the right ascension currently
on the observer's celestial meridian.



Magnitude

The magnitude system is a logarithmic scale used to describe the brightness of an object. The larger the 
magnitude, the dimmer the object.

Magnitudes are used in astronomy for historical reasons. In ancient times the stars were ranked in six 
classes of magnitude. The brightest stars were first magnitude and the faintest stars just visible to the 
naked eye were sixth magnitude.

More recently, this system had to be expanded to cover stars brighter than first magnitude and fainter 
than sixth magnitude. In 1856 the English astronomer N.R. Pogson proposed that a difference of five 
magnitudes correspond exactly to a brightness ratio of 100 to 1. The brightness ratio of two stars that 
differ by one magnitude is the fifth-root of 100, or 2.512, a quantity known as the Pogson ratio. A star that 
is two magnitudes brighter than another star is 2.512 squared, or about 6.3, times brighter than the other 
star.



Precession

Precession is the periodic change in the direction of the earth's axis of rotation. Currently the north pole of
the axis of rotation points toward the star Alpha Ursae Minoris, better known as Polaris or simply the 
North Star. But the positions of the celestial poles actually move across the sky, tracing out a circle on the 
celestial sphere every 25,800 years. So, the pole star observed thousands of years ago was not the North
Star we see today. For example, in Egypt when the pyramids were being built, the north star was Alpha 
Draconis, also known as Thuban, the brightest star in the constellation Draco.

The earth is not a perfect sphere, but has an equatorial diameter that is slightly larger than its polar 
diameter. The sun, moon, and other planets of the solar system exert a gravitational attraction on the 
equatorial bulge of the earth. It is this force that is responsible for precession.



Sidereal Time

Sidereal time is time measured by reference to the rotation of the earth with respect to the stars. Our 
common solar time is measured by reference to the rotation of the earth with respect to the sun. With 
respect to the stars, the earth takes 23 hours, 56 minutes, and 4.091 seconds to spin once on its axis. 
This quantity is known as a sidereal day. During this period the earth moves along in its orbit around the 
sun. Because of this motion, it takes roughly another four minutes before the earth has spun once on its 
axis with respect to the sun. This 24-hour period is known as a solar day.



Terrestrial Meridian

A terrestrial meridian is a great circle on the surface of the earth that passes through both poles of the 
earth's rotation. In other words, an observer's terrestrial meridian is the line of longitude he or she is 
standing on.



Universal Time

Universal time (UT) is the mean solar time in the time zone centered on Greenwich, England. It is the 
same thing as Greenwich Mean Time (GMT).



Zenith

The zenith is the point on the celestial sphere that lies directly above an observer.




